Adding Application not loading canvas page requested.

Jul 26, 2007 at 2:43 PM
Hi,

I'm not sure what I am doing wrong. I have developed my application using canvasIframeBasePage. http://apps.facebook.com/igreetingcards/

The application sends a notification to a friend stating that they have received a Greeting Card with a link to view their card http://apps.facebook.com/igreetingcards/viewcard.aspx?id=1349H-32E-1332-322T4-23233

When the user clicks the link in the notification and they do not have the application added facebook directs them to add the application but then after adding the app instead of displaying the viewcard.aspx page the user gets the canvas page http://apps.facebook.com/igreetingcards/

I have tried doing http://apps.facebook.com/igreetingcards/?cardid=1349H-32E-1332-322T4-23233 and then having it create a session variable to store the querystring("cardid") and doing server.transfer to viewcard.aspx that loads the content specific to the cardid. But when the app is added this way it does not retain the Querystring variables...

Please help.
Coordinator
Aug 7, 2007 at 2:53 AM
I think there is a returnPage setting (or something like that) you can use. There was another discussion about this. I will try to find it.
Coordinator
Aug 7, 2007 at 3:01 AM
Did you read this thread?

http://www.codeplex.com/FacebookToolkit/Thread/View.aspx?ThreadId=12427
Aug 10, 2007 at 3:22 AM
Thanks,

I just read that post and at first glance it may help. I will have to investigate a possible solution.

Regards,

Brad