ERROR: Requested value 'UnitedKingdom' was not found

May 20, 2008 at 12:11 PM
Hello there, am a newbie in facebook platform and i have tried to use the facebook developer toolkit ver 1.0 (visual C# 2005) to create a simple application but gave me this errors right at the start. this is the code i tried to run

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

namespace facebook2
    public partial class Form1 : Form
        public Form1()

        private void Form_Load(object sender, EventArgs e)
            friendList1.Friends = facebookService1.GetFriends();

can any one help please!
i have tried to edit the source file location.cs and add UnitedKingdom in the enum list but changes were not saved as it said the file was read-only. the same thing happened even when i un-checked the read only property. please urgent help needed.
May 20, 2008 at 9:47 PM
open the facebook source separately, edit location.cs, then build the solution.

then, you can just browse to the debug folder, and use the newly created library.

if this doesnt work for you, send me your email, and I will send you the working dll.
May 21, 2008 at 6:20 AM
hi schubertjr, could you please take me through that process you just recommended (tell me exacly wot to dot step by step ). my email is otherwise you could send me an email of the working dll to the above email ( cheers!
May 21, 2008 at 6:31 AM
how do i get the latest version of facebook developer toolkit?  am using ver 1.0 and i want to get the latest 1 or rather upgrade this version that am using! thanks!