Facebook Server connection issues. Anyone experiencing the same problems?

Sep 18, 2008 at 4:31 PM
Hi everyone,

I am using 1.7 version and since my app gone live, i have been seeing lots of, what appears to be facebook connection issues.

Things like:

"An existing connection was forcibly closed by the remote host " AT System.Net.Sockets.Socket.Receive (...) AT Facebook.API.FacebookAPI.GetQueryResponse
"The operation has timed out " AT Facebook.API.FacebookAPI.GetQueryResponse
"Invalid parameter" ATFacebook.API.FacebookAPI.ErrorCheck (probably not connection issue but still puzzling)

Its only a small percentage of the call that are failing but stil want to determine the reason for this.

I am guessing its problems connecting to facebook servers.

Anyone with simillar issues ?
Sep 24, 2008 at 3:52 PM
anyone having simillar problems? is it just me ?!
Sep 24, 2008 at 4:04 PM
Unfortunately the facebook platform has changed quite a lot with the introduction of the new design, since version 1.7 was launched. This being the case, you're probably running into compatibility issues. It may be worth writing a version of your app using the most recent release, and fixing it up using bugfixes from the forums. (The new toolkit release isn't quite there yet...)

The invalid parameters are likely coming from those API calls that have been changed by facebook. They changed the way sessions work, and also made some of the API calls no longer require an active session.

See http://wiki.developers.facebook.com/index.php/New_Design_Integration_Guide  for general info, and http://wiki.developers.facebook.com/index.php/New_Design_Platform_Changes for API changes.

Sep 24, 2008 at 4:35 PM
Thanks Zeus but the thing is, i have a very, very shalow integration with Facebook.

Basically I only authenticate the user with facebook; that is all - so what ever calls are related with this - IsAppAdded, get user info etc. nothing besides that.

and I have been getting these before facebook chnages june 15.... and most of the time all works well; it appears that at certain times, the connection errors occurs  in bulk so it really does look like connection issues.... I have noticed the toolkit even catches timeout exceptions and attempts to try the call again which would seem to backup my suspisions.

anyway, would love to figure out of others are also having such problems
Sep 24, 2008 at 4:43 PM
Looks like i am not the only one: http://forum.developers.facebook.com/viewtopic.php?id=17863 although this is reather old post...