trouble adding controls using vs2008

Dec 17, 2008 at 9:40 PM
I am trying to add a control to a blank vs2008 (vista) website and it keeps giving me the error "Could not load file or assembly 'facebook, version=2.0.3230.29787, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified."  (I also tried it in vs2005)

I added the control to the toolbox which automatically adds all the facebook dlls to the bin folder (facebook.dll, facebook.web.dll, facebook.web.xml, facebook.xml) so I don't see what is wrong...

I did the exact same process on my laptop using Visual Web Developer 2008 (xp) and it worked perfectly...

I have tried re-adding it over and over again but no luck, any help would be greatly appreciated

Dec 21, 2008 at 12:01 PM
me too

I read the facebook toolkit document and follow steps.
At the beginning, it work fined.
i installed AjaxControlToolkit-Framework3.5SP1.
Then,i encounter problem as same as bigbird8891.

After i installed visual studio 2008 sp1 (vista) and .net Framework 3.5 sp1,
error message are disappeared , but also doesn't work (icon disappeared in design view).

Your help is much appreciated.



Jan 19, 2009 at 12:42 AM
Any updates? Any solutions? Or are we left to figure this mystery out on our own???
Jan 22, 2009 at 10:27 PM
I had same problem.

I suspected that the designer.cs file was missing something. When you drop a FriendList in design mode it is supposed to add this to the designer.cs file, but in some cases it doesnt.

/// <summary>
        /// FriendList1 control.
        /// </summary>
        /// <remarks>
        /// Auto-generated field.
        /// To modify move field declaration from designer file to code-behind file.
        /// </remarks>
        protected global::facebook.web.FriendList FriendList1;

Hope this helps.
Jan 27, 2009 at 2:31 AM
I'm having the exact same problem as the others.  I have checked all of my projects and I don't have a designer.cs file and I'm trying to make one.

Is this a class library or something else?

Your help will be greatly appreciated!

Thanks very much!
May 26, 2009 at 2:14 AM

hi guys, i also had the same problem had anyone figure out the error....needed some help here thx in advance

Jun 10, 2009 at 6:50 AM

same problem here, what is fix?

Jun 10, 2009 at 9:03 AM

try use v2.1 beta version

Jun 10, 2009 at 11:02 PM

the 2.1 beta only comes with 3 files, do we need to at the linq.dll and the other file as well?