Falling at the first hurdle! api.users.getinfo times out

Feb 10, 2010 at 6:50 PM

Hi guys,

Sorry to say I've had little success with the initial connect tutorial.  I've setup the facebook application, xd_receivers file, scripts at the top and bottom of my page.. everything's looking good as the fbml login button appears to work fine, as does connectSession.IsConnected which toggles appropriately when I click the login button.

I also get no issues with creating a new API(connectSession)... however as soon as I use the API, e.g. API.users.getinfo().first_name I get the following error (after a considerable pause):

"A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond"

Any ideas? I'm assuming the setup is fine due to the login button working.. am I perhaps missing something in my facebook application setup (i.e. through the developer app within facebook) my details here are very scant.. all I've edited is the connect url within the connect section - everything else is blank/default.  My site is accessible through https:// but I tried changing the script links etc. to their ssl counterparts with no change.

Thanks in advance!



Feb 10, 2010 at 8:00 PM

I had the exactly the same error message at the point of trying to use the API. I'm hosting with 1and1.com and after a surprisingly quick call I had an email with proxy settings that should go in web.config...

This is what they gave me:

			<proxy usesystemdefault="false" bypassonlocal="false" proxyaddress="http://ntproxyus.lxa.perfora.net:3128"/>
      <!--   Without the following attempting to call FaceBookService.CreateSession results in:
The server committed a protocol violation. Section=ResponseStatusLine -->
      <httpWebRequest useUnsafeHeaderParsing="true"/>


Feb 11, 2010 at 8:13 AM

Excellent! Thank you so much, it seems to have helped (using my work's proxy - suppose it makes perfect sense but I'd probably have never thought about it)... at least I've moved onto another issue of security permissions on my temp folder.. but I can sort that easily enough.


Thanks again :)