API 2.0, VS 2005, ASP.NET 2.0 compatibility

Aug 11, 2008 at 1:58 PM

Hello there!

First of all, thanks for working on maintaining up-to-date the framework, even if I get a bit confused with all the changes to the functions' and properties' names.

My problem is now... The documentation recommends to get Visual Studio Express 2008, but here at work, I have Visual Studio Standard 2005. Is it problematic? I am currently trying to find out how to get around:

Could not load file or assembly 'System.Xml.Linq, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

The thing is, the whole project is in ASP.NET 2.0, and I think that it would be an headache to go to 3.5.

My question is then : is it possible to use the new toolkit with VS2005 Standard and ASP.NET 2.0 ?

Aug 11, 2008 at 3:45 PM
The release notes are correct.  2.0 of the toolkit is only compatible with VS2008.  2005 does not support LINQ, so it is not supported.
Aug 11, 2008 at 5:29 PM
However, if you are only using the binaries and not the source, 2005 will be just fine, correct?
Aug 11, 2008 at 9:33 PM
I don't believe this is the case, because once you load our binary, it will look for its Linq depenancy, which it will not find if you're running 2005.  I have not personally confirmed this with the FB Toolkit, but I've seen this happen with other projects. 
Aug 11, 2008 at 11:06 PM
This is not good; many, including myself, have not switched from 2005.  Linq dependancy "should" be optional.
Aug 12, 2008 at 12:27 AM
Yeah, its a great idea and I understand that Microsoft is behind this so they want to push their latest technologies. I can respect that, but that is not practical in the case where seasoned VS2005 (.NET 2.0) developers have a lot of projects built in .NET 2.0 to all of a sudden make them change their environment to 3.5...It would break their old projects, so these people will not follow this Toolkit as readily.

Anyway its still a good idea, but executed poorly in terms of targeting if there is no way for it to be compatible to with VS2005, the most widely used IDE at the moment in the .NET developer world.
Aug 12, 2008 at 4:13 AM

You shouldn't need VS 2008 just for development.

You will need .net framework 3.5.  But, I'm thinking you should be able to work in Visual Studio 2005.  I will try it out.



Aug 12, 2008 at 6:03 AM
Edited Aug 12, 2008 at 6:03 AM
@rpowers : yes I think you are right. Apparently (looking into it more) its simply a library addition/install so nothing neeeds to be done after installing .net 3.5 and it seems entirely backwards compatible with .net 2.0. If it works this way it is not as bad as I thought at all.

link with an explanation of this: http://blogs.msdn.com/vijaysk/archive/2008/03/20/running-asp-net-3-5-on-iis.aspx
Aug 13, 2008 at 2:56 PM
Hi, i just want to confirm thing here, my client only have 2.0 at the moment and the IT Admin doesn't want to have 3.5 on the server. So 3.5 is really not a option, so i guess i can't use the V2 version right??? (if i wrong plz let me know)

How much of work you guys think would it be to take V1.6 (or v1.7 whichever is the better)  and apply the facebook API change so at the minimum my app will work? i really don't need to latest technologie and all those toys which was force on us but probably is cool.?? just a estimate.

thx and if you have any solutions for me let me know.
Aug 13, 2008 at 5:12 PM
I installed 3.5 and it literally changes NOTHING in terms of what I had to do for code, it was just to use the libraries. I first thought it would be a major change/over haul, with manual configuration ramifications, but its really just an EXTENSION of .net 2.0 in a way, it just adds more capability/functionality, not a major change. If possible try to convince IT to install 3.5 on a test system to grasp how trivial it really is to install this. I understand the kneejerk reaction to say no, as I was on the other side of the fence myself two posts ago.
Aug 19, 2008 at 3:40 AM

@topeson: thanks for trying it out.  I don't have VS 2005 anymore and was having trouble finding a good way to test it out. 

@DevWannabe: I guess it really depends on what you want.  If you just want to sort out bugs that were introduced based on the facebook platform changes, might not be bad.  Biggest thing would be just to look at the code in Helper class for IFrame and FBML for v2.0.  Which is where we changed the functionality to deal with how facebook passes around auth information now. 

However, if you want to leverage all of the new apis and integration points.  It will be a lot of work.  The newer apis are getting progressively more difficult to code against.  That is why we made some drastic changes.  To put us in better position to support these new apis going forward.  Hopefully you can convince them to at least put .net 3.5 on the server.

Nov 18, 2008 at 8:07 PM
In my opinion, forcing developers to move to .NET 3.5 is a poor move for the FDT. Consider companies with their entire application platform based off of .NET 2.0 who want to take advantage of the FDT just for Facebook Connect. It's not reasonable to assume that everyone is in a position to move their application stack to .NET 3.5 solely for Facebook Cnnnect authentication support.