Compatible with .Net 2.0?

Dec 17, 2008 at 10:10 AM

I've downloaded the binaries and have found that it's using Linq which needs to run on .Net 3.5. I was wondering if there was a way around this, or a .Net 2.0 version or something :)

Dec 23, 2008 at 8:53 AM
I have the same problem.
I tried to downgrade to .NET 2.0 and remove Linq, but it caused a lot of problems.
Any ideas how to do it ?
Thanks a lot.
Dec 24, 2008 at 12:49 PM
Hi guys, i thinks its common sense here, if i build a car with a engine and i remove the engine i don't think my car would run :) the toolkit was built using LINQ which come with framework 3.5 only which you will need 3.5 to make it work. which suck because not everybody want to go to 3.5 yet but if that can help you we were in the position were my IT Admin didnt want to install 3.5 by fear of breaking stuff but it turn out that installing 3.5 on our server was pretty simple and didnt affect our 1.1 and 2.0 applciation at all. Framework 3.5 is more like a addon to 2.0 in a sense so don't be scrare tyo install it. I believe that you can work with the toolkit in VS 2005 but you will need to have 3.5.
Dec 24, 2008 at 1:00 PM
I am developing a Facebook desktop application and I don't believe that many users will install my application after they understand that they need to download and install .NET Framework 3.5, especially, when they don't really know and care about it.
Do you know many users that will be interested in downloading 200 MB of .NET Framework 3.5, in order to try some application ?
I personally would not do it.
Dec 31, 2008 at 1:50 AM

I've been using that for a while, I switched for 2.0 compatibility, and found alot of the missing features added, online status built in, mono compatibility, facebook IM support, being able to poke people, it rocks!