Incorrect signature error with desktop application (VB)

Jun 22, 2009 at 9:03 PM
Edited Jun 22, 2009 at 9:10 PM

I am creating a simple desktop application which currently logs in and gets the friends list.  However when I run he command to get the friends list I get an invalid signature error.  The error occures when the code for the bolded piece of code is run.  Whats going worng and how can I fix it?  I have chacked my application is desktop ad I have reset my  keys and I have even created a new application but all give the incorrect signature error.  What am I doing wrong and how can I fix it?


Public Class Form1
    Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        FacebookService1.IsDesktopApplication = True
        FacebookService1.ConnectToFacebook()
    End Sub
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        FriendList1.Friends = FacebookService1.friends.getUserObjects
    End Sub
End Class


 

Jun 24, 2009 at 2:55 AM

Hi nottud,

I also experience the same problem (invalid signature with getUserObjects()) right now. Please share your solution if you've found it because I'm still newbie.

Btw, I 'm using WPF with C#

Thanks

 

 

Jun 24, 2009 at 4:20 AM

I'm also getting the same error =(

Tried loading the sample desktop application and got the same error as well.

Coordinator
Jun 25, 2009 at 2:50 PM

I'll try this today.

Jun 28, 2009 at 1:56 PM
Edited Jun 28, 2009 at 3:09 PM

If anyone gets it to work a solution would be very grateful.  It is getting really annoying the error and I having to postpone my application until someone gives me a solution!

Jul 3, 2009 at 12:53 AM

Hi rpowers119, nottud do you have any clue for this error?

Jul 6, 2009 at 4:42 PM

No idea - I have tried for ages to sort this out and with no sucess.  It's driving me insane!

Jul 6, 2009 at 8:42 PM

I'm having the same exact problem.. driving me crazy too!   Somebody please help!  


Strangely, when I use the signature key and secret provided in the desktop application example, it works.  But if I use any other, is does not.

 

Thanks

Coordinator
Jul 9, 2009 at 2:30 PM

What version of the application are you guys using?

 

Also, can you post your application settings for you facebook application.  This will have an impact (as the way that parameters are sent for web apps and desktop apps are not the same.

Jul 12, 2009 at 12:41 AM

Application type is desktop.

My application settings are:

  • Information Update & Canvas Callback URL & Connect URL: http://www.google.com
  • Profile Box: Wide
  • Render Method: FBML
  • IFRame SIze: Smart size
  • Canvas width : Full (760)
  • Quick Transitions: Off
  • Friend Linking Access: Requested
  • Native Friend Linking : No
  • Comment Box Global Settings:Blacklist Mode
  • Allow Anonymous Comment:Yes
  • App type: desktop
  • Sandbox mode:Disable
  • SMS Integration:Disable
  • Session Secret Whitelist Exception:Enable
Developer
Jul 20, 2009 at 6:13 PM

I believe what rpowers meant to ask, along with your application settings, is what version of the toolkit are you using? This issue should have been fixed in more recent updates, so you may be using an old version with known bugs.

Jul 21, 2009 at 12:14 AM

I'm using the FB toolkit version 2.1

Jul 23, 2009 at 10:33 AM

I was using the latest version that was available at the time of making the first post!

Jul 29, 2009 at 8:01 AM

 

internal void CreateSession()
{
var auth = _auth.getSession(AuthToken);
SessionKey = auth.session_key;
uid = auth.uid;
SessionExpires = auth.expires > 0;
if (IsDesktopApplication)
{
Secret = auth.secret;
}
}

internal void CreateSession()

{

var auth = _auth.getSession(AuthToken);

 

SessionKey = auth.session_key;

uid = auth.uid;

SessionExpires = auth.expires > 0;

 

if (IsDesktopApplication)

{

Secret = auth.secret;

}

}

inside API. cs is setting secret to null. if you reset the secret to a valid secret before sending a request, it should work.
for example, I called:
 facebookService1.API.Secret = Settings.Default.secret;
facebookService1.friends.get();
and it worked. locally, i added a null check so it doesn't wipe out the secret if the auth object doesnt have a valid secret.

 

Oct 20, 2009 at 2:03 AM

My API secret is being set each time and I'm still having this issue even with the included samples.  Any clue on what this is?